Folksy Ltd

Heavy Load error

UPDATE: We think this is fixed now and Doug is writing a post for the status blog explaining what the error was, how we’ve dealt with it and the measures we’ve put in place to stop it happening again. We’ll post a link to that when it’s ready for anyone who’s interested. Thank you all for your help and patience with this - and please do let us know if you see the error message again. We really are very sorry if you or your customers experienced problems.


Hi everyone. I just wanted to let you all know that we’ve been having some intermittent issues with our servers this week. Occasionally visitors are seeing “Heavy Load” error messages on item pages. In most instances it seems to be ok when you refresh the page and it’s not happening regularly.

We thought we had identified the issue yesterday and put a fix in place but the reports this morning show that there is still something causing problems. Doug is actively working on it and thought he had identified where the issue is but it seems there may be another cause. In the meantime he has implemented an auto-scaling policy to respond to demand better and boosted the server by another 50%. We’re investigating this as our top priority and have increased the servers by 50% while we fix it.

If you experience the same problem it would really help us if you could let us know what you’re doing when you see it ie are you on an item page, trying to list a new product, adding an item to your basket.

We’re really sorry about this and working our hardest to fix it.

2 Likes

Hi Camilla i am getting the message when clicking on items and also today when i went to mark a sale as being shipped i got the error

1 Like

It’s really helpful to know you saw it on the shipping notification page too - thanks Valerie. I’ve passed that on to Doug.

2 Likes

I received a Heavy Load message this morning at about 7.15am when I was trying to renew some expired items, but whenever it showed, I refreshed the page and eventually managed to renew.

1 Like

I added a few examples to the post on the Clubhouse, but have just encountered a new one. I had just listed an item (successfully) but when I then tried to access my dashboard from the item page, I got the heavy load message.

1 Like

I’ve been getting the message for a couple of days when listing items but if I left it a minute and then tried again it was fine.

1 Like

I was editing some listings, when I received the heavy load issue

1 Like

Here’s the link to Doug’s post explaining what happened yesterday https://status.folksy.com/2019/10/12/heavy-load-notifications-this-morning/

This is happening again…now @folksycontent
I have emailed using the ‘urgent’ email address

Hi

I just got this several times when trying to relist an item, and also when I tried to load my shop page. It happened about 5 times over five minutes, but is loading as normal now.

We’re very sorry that some of you have experienced problems accessing your Folksy shops today.

The site had been experiencing some intermittent issues over the last 10 days or so, which we had investigated and solved. We also put more safeguards in place to catch increased loads before they affected the site. But then we ran a new update to one of our key servers and it broke everything. We rolled back that update immediately and the outages should now be fixed.

Doug has explained what the problem was in this blog post: https://status.folksy.com/

Once again we’re very sorry for any inconvenience caused and we work very hard to fix these issues when they arise.

I know you are all working on a fix @Folksyadmin, but thought it prudent to advise that the “heavy load” thing just happened to me today while attempting to open pages on the Folksy site. 21/10/19 at 9am.

The same happened to me at just before 9.00 this morning when trying to access my dashboard.

Thanks for letting us know, we saw it too . The issue this morning only lasted a couple of minutes before resolving itself. Doug is continuing to investigate the cause of these issues.

1 Like

I can’t load photos and my white witch is now a right mess as all her photos are gone and I can’t replace them. SOB …

It restored itself after 15 minutes so thanks @dougfolksy for whatever you did. :slight_smile: xx

This is happening again this evening…plus another error saying ’ we are sorry but something went wrong. @dougfolksy @clarefolksy

Same here, can’t get into dashboard at all @dougfolksy @clarefolksy

Same here, getting the ‘application error’ message and the ‘Heavy Load’ message :frowning:

I cant get into my dashboard at all, it says there is a heavy load

Can’t get anywhere at the min: