Folksy Ltd

Item search function

@FolksyStaff

Hi,
For the past couple of days I’ve been trying the ‘Item’ search function using the keywords “tissue box cover” (and various combinations of these keywords) and I get the following error message:

‘We’re sorry, but something went wrong.
If you are the application owner check the logs for more information.’

Most other keywords seem to work, but these specific ones do not (and these just happen to be the most common keywords for my product).

Any ideas about how to resolve this?

Thanks.

That is odd Aaron - I’ve just tried the same search with the same result. Tried searching for an item of mine & it worked as normal.

There was a separate thread here where people were saying they couldn’t find their items… Where do my newly listed items go? - #18 by kimfolksy

I’m not sure if your issue is related, but it might be worth popping a comment on that thread in case it is. I think support are tagged in there too so hopefully they can let you know.

Thanks Dee, at least I know it’s not just me :slight_smile:

I looked at the thread you mentioned (thanks for the suggestion) which seems to talk about waiting for Folksy’s robot to index products before they can become searchable. This problem seems to be more of an issue with specific keywords which are causing a search error.

Hopefully Folksy staff can figure out the cause of the problem.

1 Like

Aaron, that is such a coincidence because I was trying that exact search yesterday as I wanted to find one of your tissue boxes for my Folksy Friday board today. I got the same message, but I have no idea what it means and I’m afraid I gave up in the end. I have now noted your shop name so I can find it another time. I used to make tissue box covers, but never anything as smart as yours!

That’s such a shame, thanks for letting me know. (And thanks for the compliment!)

Yes it looks like this is the same issue that @OrukiDesign linked to.

Before the item has been indexed, this seems to cause issues on the page of search where the item is due to come up, meaning the error message comes up. This isn’t so bad if the item is due to be a few pages back as then you can still get on to the search results, but when it will be on the first page of the search results, it’s a bigger problem as you don’t see any results for that search. .

Although it should sort itself out within 24 hours, because you’ve listed/relisted items that would come under the same search both yesterday and then today, it’s likely your items from yesterday would have just been indexed, and then a new one from today didn’t get indexed which repeated the problem.

Unfortunately we thought we might have solved this yesterday, but from your report it seems like we’ve still got some more investigating to do.

1 Like

Hi Kim,

Thanks for replying @kimfolksy . My products can be found using other keywords, so it seems that my listings have been indexed.

It’s just the specific keywords ‘tissue box cover’ (and ‘Kleenex’) that produce an error message and no products appear (neither mine nor anyone else’s). When I search with the keywords ‘tissue holder’, results are returned and my products appear along with others.

The issue seems to be surrounding the keyword search function.

@AaronJosephWorkshop It’s caused by the 2 items you listed this morning, it’s just those 2 specific ones which haven’t been indexed yet. Because they’re more relevant for the phrase “tissue box cover”, they’re due to show up on the first page of that search and that’s what’s causing the error message. They’re not quite as relevant to the phrase “tissue holder” compared to some of your other items, so the first page of this search is working, but page 2 (where these items presumably will be) is not working.

Once the items have been indexed the search should return to normal, and we’ll carry on investigating what might be causing some items not to get immediately indexed.

@kimfolksy I have 106 listings with both ‘tissue box cover’ and ‘tissue holder’ as tags. Even if the two products that I listed this morning haven’t been indexed yet, shouldn’t the other 104 listings be returned as results, along with other sellers listings?

When I search ‘tissue holder’ I get listings returned (mine and other sellers). When I try the single keyword ‘tissue’ I get the error message. Why does searching ‘tissue holder’ produce results, but searching ‘tissue’ is an error message?

I should mention that I also have tote bags which were re-listed at the same time as my tissue box covers, and the tote bags are appearing in results for keyword searches ‘tote’, ‘bag’, and ‘tote bag’.

@AaronJosephWorkshop As I said, it appears to be based on which page of the results the unindexed items are due to appear on, and it will cause an error message for that whole page of the results.
Other pages of the results will show up ok, unless it was the very first page of results (although you can get to the other pages by altering the URL, page 3 of “tissue box cover” shows up fine - Search results on Folksy on Folksy but presumably all of your items are on the first 2 pages, but one of these new listings is due to show on page 1, and one on page 2, as neither of those work).

The items on the first page of results for “tissue holder” are your items, but they’re not the 2 unindexed ones, so everything on that page shows up fine. However if you try to go to page 2 of this search then you will get the error, because that is where the new items are due.

The search results for “tissue” and “tissue holder” will not be exactly the same items in exactly the same order. They will likely have some of the same results, but the order will differ depending on how relevant the search determines each item is to the search term. This suggests your items are more relevant to the search “tissue” than “tissue holder”. As you mention “tissue” multiple times in the title, description and tags, but only have the phrase “tissue holder” mentioned once in the tags, this will make them more relevant on a search for tissue than tissue holder, so more likely to be on the first page.

Relisted items don’t seem to be causing the same problems as brand new items. If these don’t get indexed, they still don’t immediately show at the beginning of recently listed as they should, but because they had previously been indexed when they had been listed before, they still show in the search results with the placement from the last time they were listed.

From what seller’s have reported to us, it also doesn’t seem to be all items listed/relisted at a certain time that are affected, but it can just be a few in one bulk relist, which is making it trickier to determine what’s causing this.

1 Like

@kimfolksy Thanks again for your reply.

Thanks for this Kim - I thought it sounded like the same gremlins.

As it happens I had a similar thing yesterday. Meant to pop a message on the other thread & forgot - sorry! I relisted these earrings at about 4.30, & just out of interest had a look in the category & they weren’t showing in the first couple of pages. When I tried to skip to the last page (where they would have been as the listing was due to expire) I got the error message. When I searched on the title they came up. I can see them on page two now so the system has since caught up.

Thanks for investigating, hope you can get to the bottom of it!

It’s been a pain and taken a little while to work out all the little odd things it’s causing (like the last pages not showing up), but Doug has had another idea now so hopefully we can get it sorted soon.

1 Like

@kimfolksy That’s good news!

Morning Kim and doug, newly listed items still not showing right, new listing this morning coober pedy opal necklace and i even tried searching for my new listed item and … nothing, even the search function has thrown a wobbly :smiley: could just be because its monday :smiley:
This is what i’m getting

We’re sorry, but something went wrong.

If you are the application owner check the logs for more information.

That’s really useful. Thanks Jacqueline. Doug is investigating now.

@JacquelineOJewellery Thanks, Doug has had another idea since you posted this, so the last change went out about 2:30 this afternoon.

If anyone notices this is still happening to items listed since this time (or that everything seems to be working as normal again) please let us know.

1 Like

Thank you Kim and Doug for your swift action, all seems to be working good x

1 Like